How to install the WiKID Server Community Edition on CentOS 6

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

How to install the WiKID Server Community Edition on CentOS 6

Dacosta
Dear all,

Anybody can help me how to install the WiKID Community Edition on CentOS 6.

I would like to build and integrate with IIS 7.5 and C# webbased.

Regards,
Dacosta
Reply | Threaded
Open this post in threaded view
|

Re: How to install the WiKID Server Community Edition on CentOS 6

Nick Owen
Administrator
Please see these installation instructions
http://www.wikidsystems.com/support/wikid-support-center/installation-how-tos/how-to-install-the-wikid-community-edition-3.x

And then use the manual:
http://www.wikidsystems.com/support/wikid-support-center/manual/how-to-install-the-wikid-strong-authentication-server

HTH

Nick


On Wed, Oct 10, 2012 at 3:50 AM, Dacosta [via WiKID Strong
Authentication Forums] <[hidden email]>
wrote:

> Dear all,
>
> Anybody can help me how to install the WiKID Community Edition on CentOS 6.
>
> I would like to build and integrate with IIS 7.5 and C# webbased.
>
> Regards,
> Dacosta
>
> ________________________________
> If you reply to this email, your message will be added to the discussion
> below:
> http://wikid-strong-authentication-forums.1491522.n2.nabble.com/How-to-install-the-WiKID-Server-Community-Edition-on-CentOS-6-tp7574689.html
> To start a new topic under Support, email
> [hidden email]
> To unsubscribe from WiKID Strong Authentication Forums, click here.
> NAML



--
--
Nick Owen
WiKID Systems, Inc.
http://www.wikidsystems.com
Commercial/Open Source Two-Factor Authentication
Reply | Threaded
Open this post in threaded view
|

Re: How to install the WiKID Server Community Edition on CentOS 6

Dacosta
Dear Mr. Nick

Thank you for your feedback. However, after try hard, I still cannot install WiKID server.

I get this error:

[root@wikid ~]# rpm -ivh ftp://rpmfind.net/linux/sourceforge/w/wi/wikid-twofactor/WiKID_Server/3.5/wikid-server-community-3.5.0.b1333-1.noarch.rpm
Retrieving ftp://rpmfind.net/linux/sourceforge/w/wi/wikid-twofactor/WiKID_Server/3.5/wikid-server-community-3.5.0.b1333-1.noarch.rpm
error: Failed dependencies:
        sudo >= 1.7 is needed by wikid-server-community-3.5.0.b1333-1.noarch

Regards,
Dacosta
Reply | Threaded
Open this post in threaded view
|

Re: How to install the WiKID Server Community Edition on CentOS 6

Nick Owen
Administrator

'yum update sudo'

On Oct 11, 2012 9:52 PM, "Dacosta [via WiKID Strong Authentication Forums]" <[hidden email]> wrote:
Dear Mr. Nick

Thank you for your feedback. However, after try hard, I still cannot install WiKID server.

I get this error:

[root@wikid ~]# rpm -ivh ftp://rpmfind.net/linux/sourceforge/w/wi/wikid-twofactor/WiKID_Server/3.5/wikid-server-community-3.5.0.b1333-1.noarch.rpm
Retrieving ftp://rpmfind.net/linux/sourceforge/w/wi/wikid-twofactor/WiKID_Server/3.5/wikid-server-community-3.5.0.b1333-1.noarch.rpm
error: Failed dependencies:
        sudo >= 1.7 is needed by wikid-server-community-3.5.0.b1333-1.noarch

Regards,
Dacosta


To start a new topic under Support, email [hidden email]
To unsubscribe from WiKID Strong Authentication Forums, click here.
NAML
Reply | Threaded
Open this post in threaded view
|

Re: How to install the WiKID Server Community Edition on CentOS 6

Dacosta
Dear Mr. Nick,

It's worked for me. However, after installation, I cannot go to the WiKIDAdmin, port 443 doesn't open on CentOS 6. When I go to the IP of server http://172.16.1.254, it redirect to https://172.16.1.254/WiKIDAdmin/ , it means port 80 is working. How can I config port 443 so I can go to the WiKIDAdmin?

Regards,
Dacosta
Reply | Threaded
Open this post in threaded view
|

Re: How to install the WiKID Server Community Edition on CentOS 6

Dacosta
[root@otp ~]# yum install java-1.6.0-openjdk
Loaded plugins: fastestmirror, presto
Loading mirror speeds from cached hostfile
Setting up Install Process
Package 1:java-1.6.0-openjdk-1.6.0.0-1.49.1.11.4.el6_3.x86_64 already installed and latest version
Nothing to do
[root@otp  ~]# java -version
java version "1.7.0_07"
Java(TM) SE Runtime Environment (build 1.7.0_07-b10)
Java HotSpot(TM) 64-Bit Server VM (build 23.3-b01, mixed mode)
[root@otp  ~]#
Reply | Threaded
Open this post in threaded view
|

Re: How to install the WiKID Server Community Edition on CentOS 6

Dacosta
In reply to this post by Dacosta
[root@otp ~]# /usr/sbin/alternatives --config java

There are 2 programs which provide 'java'.

  Selection    Command
-----------------------------------------------
 + 1           /usr/java/latest/bin/java
*  2           /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/bin/java

Enter to keep the current selection[+], or type selection number: 2
[root@otp  ~]# java -version
java version "1.6.0_24"
OpenJDK Runtime Environment (IcedTea6 1.11.4) (rhel-1.49.1.11.4.el6_3-x86_64)
OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)
[root@otp  ~]#
Reply | Threaded
Open this post in threaded view
|

Re: How to install the WiKID Server Community Edition on CentOS 6

Dacosta
I have solved the problem by command:

/opt/WiKID/conf/templates/wikid-firstboot.sh

Thank you very much!

Regards,
Dacosta