WiKID app for iPhone OS 4.0?

classic Classic list List threaded Threaded
26 messages Options
12
Reply | Threaded
Open this post in threaded view
|

WiKID app for iPhone OS 4.0?

James
Looks like the app bombs after installing the latest iPhone OS.  Tried re-registering and the app fails at the 'add a new domain' step.

Any ETA on an updated client?
Reply | Threaded
Open this post in threaded view
|

Re: WiKID app for iPhone OS 4.0?

Taylor
I'm in the same boat.  Upgraded 3GS to OS 4.0 and the WiKID client crashes after I enter my pin.
Reply | Threaded
Open this post in threaded view
|

Re: WiKID app for iPhone OS 4.0?

Levi
In reply to this post by James
I've also noticed that the app crashes in the same fashion when I attempt to send the diagnostic logs (I had found another thread that allows turning on a debug mode from the app's settings, and followed the instructions, but am unable to get the crash logs to send).  It seems it may just be a general issue with accessing the network stack, or something that's common to all those communication scenarios (getting a one-time use PIN, registering a new domain / server ID, and sending crash logs).

I reproduced this on my 3GS after upgrading to iOS 4.0, and the same crashes occur on my new iPhone 4 as well.
Reply | Threaded
Open this post in threaded view
|

Re: WiKID app for iPhone OS 4.0?

Nick Owen
Administrator
In reply to this post by Taylor
Yes, we're working on it. wrestling with some xcode issues right now.
it's not letting us compile any 4.x apps.

On 06/24/2010 03:28 AM, Taylor [via WiKID Strong Authentication Forums]
wrote:

> I'm in the same boat.  Upgraded 3GS to OS 4.0 and the WiKID client
> crashes after I enter my pin.
>
> ------------------------------------------------------------------------
> View message @
> http://wikid-strong-authentication-forums.1491522.n2.nabble.com/WiKID-app-for-iPhone-OS-4-0-tp5206255p5216549.html
>
> To start a new topic under WiKID Strong Authentication Forums, email
> [hidden email]
> To unsubscribe from WiKID Strong Authentication Forums, click here
> <http://wikid-strong-authentication-forums.1491522.n2.nabble.com/subscriptions/Unsubscribe.jtp?code=bm93ZW5Ad2lraWRzeXN0ZW1zLmNvbXwxNDkxNTIyfC05OTU0NDk1ODA=>.
>
>

--
Nick Owen
WiKID Systems, Inc.
http://www.wikidsystems.com
Commercial/Open-source Two-Factor Authentication
http://twitter.com/wikidsystems
#wikid on irc.freenode.net
http://www.securitybsides.com/BSidesAtlanta  10/8/10 Please come!

Reply | Threaded
Open this post in threaded view
|

Re: WiKID app for iPhone OS 4.0?

Greg Haygood
<big old groan that you can hear from 3 doors down ...>

Problem has been identified and solved.  Apparently Apple made some "minor" change in the networking code for iOS4 that now requires the error response value -- which may not ever get used! -- to be initialized to nil.  I've confirmed that changing:

NSError *error;

to

NSError *error = nil;

restores full functionality to the client.  I'm submitting it to Apple, so hopefully they will review and approve quickly.  Thanks for everyone's bug reports and patience!

Reply | Threaded
Open this post in threaded view
|

Re: WiKID app for iPhone OS 4.0?

PLBarton
Any idea when Apple will make this change publicly available?  I am leaving for 4th of July vacation and could really use this before i leave.
Reply | Threaded
Open this post in threaded view
|

Re: WiKID app for iPhone OS 4.0?

Greg Haygood
Unfortunately they provide no visibility into their work queue.  I submitted updates to 3 different apps last weekend: one was reviewed and approved yesterday, but the other 2 have not even started yet.
Reply | Threaded
Open this post in threaded view
|

Re: WiKID app for iPhone OS 4.0?

Greg Haygood
Apple just approved the app update (v3.4), so it should be available within 24 hours.  Let us know if there continue to be problems with iOS4.
Reply | Threaded
Open this post in threaded view
|

Re: WiKID app for iPhone OS 4.0?

iamjeff
Phone: iPhone 3GS iOS4


For me it is still not working with the updated version.

Here are the steps taken:

Downloaded & updated wikid client - started app on phone and it crashed right after the pin entry, same as 3.3.

Powercycled phone, tried again with same results.

Deleted app from phone - resync'd phone same results.

Deleted app from phone & PC, downloaded app again - same results.

The app still reports itself as version 3.3 in the info and settings area on the phone.

Any suggestions?

Reply | Threaded
Open this post in threaded view
|

Re: WiKID app for iPhone OS 4.0?

Greg Haygood
Oops, I forgot to update the version number that gets displayed.  I'll dig around some more to see what else might be going on.
Reply | Threaded
Open this post in threaded view
|

Re: WiKID app for iPhone OS 4.0?

Greg Haygood
Apparently I missed a spot that was still tripping up the 3GS.  This time I confirmed that it's all working on a test 3gs device.  I'm submitting another 3.4 to Apple now.  

Thanks!
Reply | Threaded
Open this post in threaded view
|

Re: WiKID app for iPhone OS 4.0?

Levi
We have two iPhone 4's here as well, both updated to 3.4 (the first one Apple approved yesterday, that still reports 3.3 in the version info); one exhibits the exact same symptoms as this 3GS-only issue (crashing after entering the PIN).  The second device isn't registered yet, and it no longer crashes after entering the server / domain code; I'm able to set my PIN and receive a registration code - however when entering it into the ADRegister.jsp page (which is working fine for other clients) I get 'Invalid registration code'.
Reply | Threaded
Open this post in threaded view
|

Re: WiKID app for iPhone OS 4.0?

James
Same experience here, I installed the 3.4 version posted 7/5 from the app store.  I can create a passphrase and set my pin, but when trying to enter the registration code with our system receive the error 'Invalid registration code'.  

Going back to the phone, if I enter the passphrase & PIN the app will crash.  Not sure if this is just because the handshake is failing (neeing to finish the registration) or if there is another separate issue with the application.
Reply | Threaded
Open this post in threaded view
|

Re: WiKID app for iPhone OS 4.0?

Nick Owen
Administrator
This should be fixed in the next release which has been submitted to
Apple.  We'll let you know when it is out there.

On 07/12/2010 10:41 AM, James [via WiKID Strong Authentication Forums]
wrote:

> Same experience here, I installed the 3.4 version posted 7/5 from the
> app store.  I can create a passphrase and set my pin, but when trying to
> enter the registration code with our system receive the error 'Invalid
> registration code'.  
>
> Going back to the phone, if I enter the passphrase & PIN the app will
> crash.  Not sure if this is just because the handshake is failing
> (neeing to finish the registration) or if there is another separate
> issue with the application.
>
> ------------------------------------------------------------------------
> View message @
> http://wikid-strong-authentication-forums.1491522.n2.nabble.com/WiKID-app-for-iPhone-OS-4-0-tp5206255p5283179.html
>
> To start a new topic under WiKID Strong Authentication Forums, email
> [hidden email]
> To unsubscribe from WiKID Strong Authentication Forums, click here
> <http://wikid-strong-authentication-forums.1491522.n2.nabble.com/subscriptions/Unsubscribe.jtp?code=bm93ZW5Ad2lraWRzeXN0ZW1zLmNvbXwxNDkxNTIyfC05OTU0NDk1ODA=>.
>
>

--
Nick Owen
WiKID Systems, Inc.
http://www.wikidsystems.com
Commercial/Open-source Two-Factor Authentication
http://twitter.com/wikidsystems
#wikid on irc.freenode.net
http://www.securitybsides.com/BSidesAtlanta  10/8/10 Please come!

Reply | Threaded
Open this post in threaded view
|

Re: WiKID app for iPhone OS 4.0?

Greg Haygood
Apple finally approved the update last night, so it should be in the AppStore today.  Please let us know if you continue to have issues.
Reply | Threaded
Open this post in threaded view
|

Re: WiKID app for iPhone OS 4.0?

iamjeff
I just downloaded the latest from the itunes store - July 13th, 2010 date.  

App works great on my 3GS - all screens updated to 3.4 as well :)

Thanks for the quick fixes.
Reply | Threaded
Open this post in threaded view
|

Re: WiKID app for iPhone OS 4.0?

James
I'm continuing to receive an error attempting to register using the code provided by the app.  I tried updating first, then removed the app altogether and downloaded it 'fresh' from the app store.  Each time I'm able to create a passphrase & PIN, but the registration code isn't accepted.  I have noticed the code has been the same each time, using the 7/5 and 7/12 versions of the app, regardless of what passphrase I use.  Is this generated from the phone hardware itself?  For some reason I thought it would change.
Reply | Threaded
Open this post in threaded view
|

Re: WiKID app for iPhone OS 4.0?

Levi
Same experience here too - registering gives the same exact code that didn't work under the previous version, and still doesn't work.

Is the fix that Nick mentioned a separate version that's still awaiting approval, or should it have been part of 3.4.1?  Since Greg had said he submitted the fix for the 3GS issue before I posted the registration woes, I'm not sure if there's yet another update still pending approval... either way, the current version in the App Store does not work for me.
Reply | Threaded
Open this post in threaded view
|

Re: WiKID app for iPhone OS 4.0?

Nick Owen
Administrator
Are you testing with the 88888888888 domain?

On Tue, Jul 13, 2010 at 11:20 AM, Levi [via WiKID Strong
Authentication Forums] <[hidden email]>
wrote:

> Same experience here too - registering gives the same exact code that didn't
> work under the previous version, and still doesn't work.
>
> Is the fix that Nick mentioned a separate version that's still awaiting
> approval, or should it have been part of 3.4.1?  Since Greg had said he
> submitted the fix for the 3GS issue before I posted the registration woes,
> I'm not sure if there's yet another update still pending approval... either
> way, the current version in the App Store does not work for me.
>
> ________________________________
> View message @
> http://wikid-strong-authentication-forums.1491522.n2.nabble.com/WiKID-app-for-iPhone-OS-4-0-tp5206255p5287950.html
> To start a new topic under WiKID Strong Authentication Forums, email
> [hidden email]
> To unsubscribe from WiKID Strong Authentication Forums, click here.
>



--
--
Nick Owen
WiKID Systems, Inc.
404.962.8983
http://www.wikidsystems.com
Commercial/Open Source Two-Factor Authentication
Reply | Threaded
Open this post in threaded view
|

Re: WiKID app for iPhone OS 4.0?

Nick Owen
Administrator
In reply to this post by James
The registration code that is returned should be a different
alpha-numeric each time and should only be returned after the PIN is
double-entered.

Are you testing the 888888888 domain?

On Tue, Jul 13, 2010 at 10:22 AM, James [via WiKID Strong
Authentication Forums]
<[hidden email]> wrote:

> I'm continuing to receive an error attempting to register using the code
> provided by the app.  I tried updating first, then removed the app
> altogether and downloaded it 'fresh' from the app store.  Each time I'm able
> to create a passphrase & PIN, but the registration code isn't accepted.  I
> have noticed the code has been the same each time, using the 7/5 and 7/12
> versions of the app, regardless of what passphrase I use.  Is this generated
> from the phone hardware itself?  For some reason I thought it would change.
>
> ________________________________
> View message @
> http://wikid-strong-authentication-forums.1491522.n2.nabble.com/WiKID-app-for-iPhone-OS-4-0-tp5206255p5287663.html
> To start a new topic under WiKID Strong Authentication Forums, email
> [hidden email]
> To unsubscribe from WiKID Strong Authentication Forums, click here.
>



--
--
Nick Owen
WiKID Systems, Inc.
404.962.8983
http://www.wikidsystems.com
Commercial/Open Source Two-Factor Authentication
12