WikiD on VirtualBox VM

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

WikiD on VirtualBox VM

Mugurel
Hello,

I am trying to implement the WikiD software in our company and I am playing with it in a VirtualBox CentOS 6 64 bit VM. I was able to install the software just fine and configure the domain. Unfortunately, I am unable to connect to the WikiD server using my client on Mac OS X. I keep getting the following error:

Could not obtain configuration for: xxxxxxxxxxxx

When I start the client in debug mode, I can see the following:

Could not connect to servercode: xxxxxxxxxxxx

The VM only has 2 IPs and has Internet access. I spinned up the VM using Vagrant so I made it accessible through 192.168.50.4. I can access the interface just fine using this IP and can telnet this IP on port 80. Is this failing because I'm lacking a routable IP? Thanks in advance.
Reply | Threaded
Open this post in threaded view
|

Re: WikiD on VirtualBox VM

Mugurel
I have actually set it up on a physical server and I'm still getting the same error. Nothing in the server logs and in the client logs it throws the same error. Any idea what I'm doing wrong?
Reply | Threaded
Open this post in threaded view
|

Re: WikiD on VirtualBox VM

Nick Owen
Administrator
In reply to this post by Mugurel

Yes, the tokens talk to your server over port 80. It needs to be routable.

Nick

On Nov 9, 2015 5:31 AM, "Mugurel [via WiKID Strong Authentication Forums]" <[hidden email]> wrote:
Hello,

I am trying to implement the WikiD software in our company and I am playing with it in a VirtualBox CentOS 6 64 bit VM. I was able to install the software just fine and configure the domain. Unfortunately, I am unable to connect to the WikiD server using my client on Mac OS X. I keep getting the following error:

Could not obtain configuration for: xxxxxxxxxxxx

When I start the client in debug mode, I can see the following:

Could not connect to servercode: xxxxxxxxxxxx

The VM only has 2 IPs and has Internet access. I spinned up the VM using Vagrant so I made it accessible through 192.168.50.4. I can access the interface just fine using this IP and can telnet this IP on port 80. Is this failing because I'm lacking a routable IP? Thanks in advance.


If you reply to this email, your message will be added to the discussion below:
http://wikid-strong-authentication-forums.1491522.n2.nabble.com/WikiD-on-VirtualBox-VM-tp7575196.html
To start a new topic under General Discussions, email [hidden email]
To unsubscribe from WiKID Strong Authentication Forums, click here.
NAML
Reply | Threaded
Open this post in threaded view
|

Re: WikiD on VirtualBox VM

Mugurel
In reply to this post by Mugurel
Yeah, I set it up on a routable IP but I'm still doing the same. Any ideas what I might be doing wrong?
Reply | Threaded
Open this post in threaded view
|

Re: WikiD on VirtualBox VM

Nick Owen
Administrator
For the web record:  the server code needs to be based on the routable
IP addres, zero-padded.

On Mon, Nov 9, 2015 at 7:35 AM, Mugurel [via WiKID Strong
Authentication Forums] <[hidden email]>
wrote:

> Yeah, I set it up on a routable IP but I'm still doing the same. Any ideas
> what I might be doing wrong?
>
> ________________________________
> If you reply to this email, your message will be added to the discussion
> below:
> http://wikid-strong-authentication-forums.1491522.n2.nabble.com/WikiD-on-VirtualBox-VM-tp7575196p7575199.html
> To start a new topic under General Discussions, email
> [hidden email]
> To unsubscribe from WiKID Strong Authentication Forums, click here.
> NAML



--
Nick Owen  --  WiKID Systems, Inc.
http://www.wikidsystems.com
Commercial/Open Source Two-Factor Authentication
http://twitter.com/wikidsystems | #wikid on freenode.net
Get our low-volume newsletter - Notices, updates : http://eepurl.com/zzUeP